How to reinstall KiCad 5.1.2 to fix problems


#1

Help Needed: How to reinstall Version 5.1.2, to fix performance issues.

Quick summary of problem : Version 5.1.2 was working great, then had serious problems. Reinstalled it, without uninstalling first, **DID NOT FIX PROBLEMs . Then, UNINSTALLED it FIRST, then reinstalled, DID NOT FIX PROBLEMS. How do I do a clean reinstall of 5.1.2 to fix problems, or fix problems another way?

Installed on Windows 10-64, used Windows “Add or Remove Programs” app to uninstall

Likely cause of problem : I had 16 programs, etc, open when using KiCad. Might have run out of “resources.” (Amateur’s guess)

How problem developed : I was looking at the 3D Viewer, and it was working perfectly. But, as I rotated the PCB, suddenly, the image changed. The green PCB changed to a dark color. The image became blurred, and the entire screen had to refill, in small rectangular blocks, taking about 10 seconds. Refilling starts in lower left corner, and finishes in upper right corner. Then the image becomes clear again.

Serious other problems soon followed, and KiCad became unusable. Then I tried the reinstalls.

Quick History:

Upgraded from 4.0.7 to 5.1.2 a couple of months ago. Windows 64 installation.

Started over with libraries and schematics, allowing a “clean” install.

WORKED GREAT! Designed 2 boards.

Current Status:

1) 3D viewer still screwed up, the same as before.

  1. Printing Gerber layers, using “Fit to page,” the prints come out various sizes. Sometimes full screen, other times roughly 1:1.

  2. ??? I’m sure there are more problems to be discovered.

PLESE HELP:

Just finishing 1st PCB for a new client, must design another ASAP (had planned to start this weekend).

KiCad must be trustworthy before starting new board.

Thanks for any help!!!

P.S. Couple of details :

First reinstall, used original 5-15-19 download (1,171,336 KB), and the 2nd reinstall, used a new download 7-4-19 (1,171,365 KB). Same bad results both times.


#2

Do you have another computer? I’d see if those files are still ok, by project. If they were open for writing and things crashed, it might be they are corrupted and KiCad is ok.

Sorry to suggest this bad news.