TI Launchpad dead IO ports


#1

When I was putting together my benchbuddy project project awhile back I ran into a dead IO port problem with the launchpad board I was using. I decided to add an encoder to my version of the project but in the middle of developing the software end an entire IO port (multiple pins) went dead. I thought I set up the encoder circuit with plenty of headroom to work with the 3.3v voltage level but something went wrong. Any tips on how to do this better? Or other common causes of dead ports on dev boards?


#2

How were you verifying the dead port? Is it possible there was some other kind of signal injected into it during operation?

Also just to clarify, these pins are specifically not 5V tolerant?


#3

I ran some simple code to enable an IO port and toggle the output of pins on that port high and low. The code worked with pins on other ports but the dead pins just stuck at a voltage between 0-3v3. No high low. The only input to those specific dead pins was that encoder circuit.

The launchpad boards are 3v3. I designed the control section to be 3v3 and selected the lower power 3v3 versions of all the ICs used in project.


#4

Is it possible those are not properly configured? Sounds like their output might be set to “tristate”. Did you explicitly stated what each pin is supposed to do in a config file somewhere?

Said another way, have you ever seen the pins in question working?

Im not familiar with Launch Pad, so you night need to ask some of the people that are more familiar with that platform.


#5

They’re configured right. I don’t think they’re tristate. I can run a simple input program like the one below to setup the pinout and toggle the internal pullup/pulldown. Two of the three pins(2.3, 8.2) correctly switch between 3v3 and 0v. The other just sits at 0v. The same pin doesn’t toggle high/low output either when I run a simple output toggle program. It just sits at 0.022v out.

I wouldn’t waste too much time thinking about this. I just wanted to see if I was doing something horribly wrong.