HELP: Can't select edge cut lines using KiCAD 6

I have run into a KiCAD 6 problem and I don’t see anything online that seems relevant. I’m taking an existing design and re-doing the layout for a new form factor. So I want to redraw the edge cuts layer for my new PCB outline… but KiCAD won’t let me select the existing edge cut layer lines for some reason. I’ve tried right clicking, left clicking, using a select box around the entire PCB outline, etc and yet for some reason I can’t select it (my goal is to delete the oid PCB outline once I can select it). It’s like the edge cut layer lines that form the PCB outline are visible but not “really” there to click on.

I tried clicking on the lines at all different grid space settings to see if that was the issue but no matter what grid I went to the tool still wouldn’t let me select the edge cut layer lines.

Any thoughts or ideas?

I don’t have KiCad v6 available to me at the moment, but look into the Selection Filter settings. PCB Editor | 6.0 | English | Documentation | KiCad

If no luck, you could just import the netlist into a new PCB again if feasible.

Worst comes to worst, close KiCad, make a copy of your *.kicad_pcb files, open it in you favorite text editor, and look for fp_line, fp_arc, and fp_poly entries with Edge.Cuts in the line as well and delete them. EDIT. The entries may start with gr_ instead of fp_ too. This is definitely “hacky”.

Would be glad to have a remote desktop session with you to to get another set of eyes on it. Hit me up.

Edge cuts are usually yellow but you arrow is pointing to a white line. I know it could be changed but perhaps just a simple mistake? Also, if I’m not mistaken, PCB outlines can be imported from a template or as a footprint, so it may have something to do with it. Oh, and perhaps you can try to use an older release of KiCad or the exact version your client used.

Yeah, I had this. Make sure you’re on the edge cuts layer, otherwise it wants to only pick the layer that’s selected.

Thank you both for your input. I’m 99.9999% sure that I am on the edge cut layer when trying to select the lines but kiCAD still acts as if the lines are not there to select. If I draw new lines on the edge cut layer I am able to select and delete them… just not the old lines from the previous layout.

I will look into the selection filters that Slawek mentioned. Not sure if I trust myself enough to fiddle with the text file as I’ve never done this before but if I run out of other options I may give it a try.

Yeah it’s probably the selection filter not having “Graphics” checked:


Yea… its was the selection filter. Although the issue was not having the “locked items” selected… not the graphics. Apparently my board outline was locked and I couldn’t select is since the filter didn’t have locked items checked.

Thank you so much everyone! Can’t thank you enough!