Grant's Build Log


#1

Hi all,

I’ve got a front-facing blog that I’m hoping to turn into formal learning prose, or at least a more collated set of posts.

This will be the place I really screw up, and post the wrong things, and work things out over time. Happy to hear other’s opinions as I go. Thanks all!


#2

Welcome! Looking forward to seeing your progress here!


#3

Thanks Chris.

In for a penny, in for a pound I’ve always heard. I like to add ‘work out the change later’. This is pretty much my approach to most of my education in life. Have a stupid idea and a drive to at least half finish it, and you’ll work out some stuff in between.

A pretty stable job that’s creative in its own right, leaves me day dreaming often of solutions that don’t exist. Silly one’s, small one’s. One’s that just make a bit of a difference to my life, and maybe other’s a tad envious in the process. A slightly clever solution, or maybe a dumb one, but one that needed to be made.

Anyway, this brings me to the following picture.

This is a TPS25740. For all I care in terms of the documentation I read it’s;

Applications
• USB-PD Adaptor (data-less)
• Dedicated Charging Port (data-less)

And that’s where the journey’s starting. The next post will be about the charging solution I opted to purchase that wasn’t delivering the specs it promised. I think with some tests I did they’re even changing the design and re-releasing the product… Oops! That’s my first little electrical engineering achievement.

I’ve no idea how to get a functional end product but I have enough tools and enough intent to at least have no excuse not to try.

My achievement in the medium term would be to have a USB-C port that pulls a 14v Nominal DC battery and supply 20V at up to 5A (according to spec). There’s likely solutions out there, at least the one’s I’ve tried are fakies. And it’s not about the product, it’s about the understanding.

Half the time I’m talking to myself in these posts, half the time I feel like I’m talking to the judge in myself and begging for approval. Ignore my rants!


#4

Amazon sells an adapter that runs 40 bucks and comes from a company that’s entire existence is ‘batteries’. Makes little sense to name the company as there’s no guarantee that I’m right, at all, ever. And in this case I may have just been unlucky.

I have a couple of ‘90W’ USB-C charging converters. They basically converted DC in to 20V up to 4.5A. Below is a screenshot of their specs.

I’ve had these things laying around for a short while and they’ve been on a photo-shoot or two and not really lived up to their name.

Next steps were to test properly.

  • I had two of the same device so I could confirm this wasn’t a single device defect.
  • I had a USB-C load meter that confirmed the following;
  • Apple AC Adapter > Load Meter > Apple USB-C Charging Cable > Macbook Pro w/ an average output of 20V @ 4.5V (I’m rounding to be clean)
  • Company Battery > Company USB-C PD Converter > Load Meter > Apple USB-C Charging Cable > Macbook Pro w/ an average output of 20V @ 3A.
  • At this point the problem is either the battery or the converter. Other variables were the same.
  • I took apart one of the adapters in order to inject a guaranteed 20V @ 4.5A. Thinking back I could’ve loaded it with 4.5 and see what happens but I’m glad I didn’t have that idea at the time.
  • The DC Bench Power Supply gave 20V at up to 4.5A and the result was the same… 20V @ 3A.
  • If functional it should be drawing another amp and a half. Strangely 20V guarantee’s this is at least USB-C designed and functioning at that level, but we’re restricted to 3A. This could be simply firmware misconfiguration? Or a functional design error that doesn’t detect for above 3A delivery, and I’m sure these adapter designs are outsourced on the cheap…

By this point I was in contact with the company and they took all my information and responded to me. They confirmed my issue and offered full refunds or a replacement that unless I wait until March (?) they’d likely fail all the same. I’m including the e-mail because I think there’s more to it than what they’d like to let on, but maybe others input would guide me right. I’ve avoided any personal information stuff;

Hello Grant,

I am following up with you regarding the converters. So we did find out that you are supposed to be receiving 4.5amps maximum.
We believe the converters you have received are defective. Our way to resolve this is usually to replace them but, our theory is that the replacement converters will give you the same issue. We are expecting a new shipment of converters sometime in March. If you are willing to wait, we can ship out two converters. If not, we can go ahead and issue you a full refund for both XXXX power bank packages.

Please advise.


#5

I can only post 1 image per post!


#6

My mind wanders. I’m curious whether tests were done and a defect in the design was discovered… or they were marketed and never caught as not delivering their supposed specs… And it makes me question company ethics and safety, cut corners… etc.

I’m sure others are going to point at the chip on this thing and be like… it’s a dummy converter. I don’t know half the components on the board still. I’ll be going down the journey of reverse engineering this thing to understand it more. If anyone can point at things on it and be like, that’s a capacitor, idiot! I’d appreciate it.

Just don’t do it with the capacitors, I’ve at least got those down so far…


#7

This is what I see - I am not a professional, just a hobbyist hardware person that works in IT on software/systems all day…

Looks like electrolytic caps (big round ones), smt caps ( small tan parts), smt resistors (small black parts), inductors (donut), and maybe a smt transistor near the top ( 3 legs ).

Are there any parts on the back?


#8

There also looks to be an 8pin SOIC package below the inductor. This could be the power converter (guessing!) - but I guess you already identified that.


#9

Is that Jason Cerundulo’s board from Tindie?

For some background info on USB C (about all I know about it as well), you might want to listen to Jason talk about it on The Amp Hour:

I’m curious about this bit:

My achievement in the medium term would be to have a USB-C port that pulls a 14v Nominal DC battery and supply 20V at up to 5A (according to spec). There’s likely solutions out there, at least the one’s I’ve tried are fakies. And it’s not about the product, it’s about the understanding.

Namely what do you mean ‘pulls a 14V battery’. Are you using the 14V (ostensibly a car battery) as a source for the USB C? Or are you looking to charge the 14V as a sink?


#10

To relay what I recall from Jason’s episode, the TPS part is looking to communicate with the source of power (in this case your power converter board). I think it needs to get the “all clear” from the board in order to accept the full 100W, which I am guessing that board is either unwilling or incapable of doing. What is the marking on the SOIC8 package?


#11

Thank you! I’ve decided to take some closer photographs of this little board for everyone to peek at.

I’m now extremely tempted to pick up a digital microscope, I know I’ll be going down SMT soldering at some point sooner than later and my eye’s and phone’s can only pick up so much detail on these little buggers.


#12

Hi Chris,

Yes in the background that is Jason’s board. I’ve had some conversations with him and follow his blog, it’s Jason that sent me here :slight_smile:

I’m using batteries that are supplied as ‘V-Mount’. They run the gamut a bit in terms of spec, but can do typically 12V and up to 5/10A. Here’s one that’s ~14V at 14A.

http://www.idxtek.com/products/duo-c198

http://www.idxtek.com/product-category/v-mount-batteries/

Jason’s board doesn’t fulfill what I’m looking for, you’re right I need to expand on his solution. TI has an eval board that I’ve picked up that with a few DIP switches should actually just do the job right away (check for 20V @5A from the source / make sure the cable can supply it, and then deliver)…

Here was Jason’s advice;

To do this, you would need to put together a board with the USB-C PD chip,
a microcontroller, and a power converter circuit. My board only has the USB
PD chip to convert the BMC-based communication on the CC line into I2C. You
can use that chip to advertise power capabilities and accept requests for
power. The power converter circuit would actually deliver the power.
Unfortunately, this is not exactly a beginner level project. If you’re just
starting out with EE, I would recommend breaking this into chunks and
solving each on in turn. A good first step would be to replicate my set up
for the Easy Bake Oven. You don’t actually need the oven, but getting an
Arduino to get the higher voltage out of the charger would help you get
your setup together.

And to clarify, yes I’m looking to use the battery as a supplier of power, my board as the converter to meet full charging specs of a Macbook Pro 2016 (85 watts). In a post or so I’m hoping to deconstruct heavily the compartmentalising I’ll need to do in terms of understanding the individual aspects of the solution. USB-C PD is already a losing battle, and only one aspect of this journey! But I’m learning a lot by proxy with this so I’m continuing blind.


#13

I sadly can’t read them too well, but there are two of those on the top board and a couple of larger packages on the back. I’ve got pictures of both up close below and a PDF Link to the Southchip;

Southchip SC8802QDER

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&ved=0ahUKEwi0qZOdxILZAhXpy4MKHV0yBY8QFggrMAA&url=http%3A%2F%2Fwww.cypress.com%2Ffile%2F372576%2Fdownload&usg=AOvVaw38AHqJHacOHxzr31n6TBKa


#14

Wait he sent you here but he doesn’t hang out here himself?? I’mma have to give him a talking to :smiley:


#15

Slow progress this week in general with a busy schedule but my geek toy arrived and figured I’d share a few images. I’ve wanted to know what those IC’s were and here we are. Two of the first, and a single of the second and third… And notice on the 2nd… Mistake? Short? Whoops? :slight_smile: This tool already paid for itself in joy.

Whoops


#16

Which microscope did you use for these photos? They are very clear.


#17

It’s the Andonstar ADSM302 – nifty little thing with a few quirks but so far zero complaints. Minor niggles.

Here’s the pinout for the chip with the short highlighted. Would it be worth fixing? There’s also a disgusting mess further down the board. WIll post in a few. It’s quite the testament to how fun this microscope is at tearing apart at things on a minor level. I’m already a detail freak.


#18

Here’s the bottom of this expensive little adapter with clear poor quality control. I’m almost not embarrassed to name them anymore as a way for others to pay maybe closer attention… Only if requested maybe.

Here’s an image of a mess further down the board.

Whilst I was there I got out my iPhone X and took a look at the OLED display. Not terribly exciting. What’s a bit annoying is the quality control or… whatever you’d like to blame, for the extremely dirty lens under the front of the display. Here’s an image. This microscope is making me question things like never before. Quite the fun journey. I’m following circuits by hand in order to work them out without prior knowledge, it’s ass backwards but quite an achievement even when I’m only 1/20 right.

Gross, huh?! Definitely might soften the odd pimple or two but not a choice I wanted them to make with some random dust and grime :stuck_out_tongue:


#19

Wow those are some nice close ups! I’m surprised that board made it past quality control. Or maybe the problem is that there was no quality control.


#20

Thanks, I agree it’s quite shocking! This isn’t a very expensive microscope and a few seconds under it reveals so much, so quickly…

In the mean time I found a fun compendium of electronics related links on github. May share this elsewhere on the forum if no one has seen it, but there’s some fun KiCAD addon links and so forth;