Getting to blinky; custom 7(555) not shown in 3D view

Thank you for the Getting to Blinky course! I’m going through it now, and when I made it to this part of the series, showing the 3D viewer, I noticed there was a 3D rendering of the 7555 chip on the board:
https://www.youtube.com/watch?v=D_7Y33AoagY&list=PLy2022BX6EspFAKBCgRuEuzapuz_4aJCn&index=6

I’m unfortunately not seeing that that in my view:

Should I be concerned?

Not concerned! That’s likely because your KiCad is having problems finding the 3D model. Have you tried to update it manually? Go to PCBnew (layout program) and mouse over the 7555 footprint and hit the “e” key (or right click -> Properties) to get to the edit section. Then there should be a “3D Settings” tab at the top. Do you see anything listed on that page?

That’s helpful! I can probably get it working, but I’ll share a screenshot of what I’m seeing in case anything comes to mind:

KiCad was installed via Homebrew. My first thought is to look for https://github.com/KiCad/kicad-packages3D on my laptop, but now I’m seeing there’s a video you produced specifically for this type of scenario (https://www.youtube.com/watch?v=M1plXo8oLrQ), so I’ll watch that and report back when there’s free time. Thank you so, so much for your help!