Footprint is not getting aligned to board


#1

I was trying to create the PCB layout using KiCAD with reference to “DESIGNING A PCB IN KICAD IN 20 MINUTES” video. At one step when we I go into the PCB layout 3D diagram, I can see those board footprints are not getting properly aligned. Please find the attachment, I have attached a screen of the same.

Could you please help me with this.

Thanks in advance


#2

Probably a question better posted to the KiCad Fourum where you will get a better qualified answer - but you can check/verify the rotation in the footprint editor, in the Part Properties sheet. There is a 3D tab and there are the setting to fix any orientation issues.


#3

Even i have faced these issues long back. I have modified the 3D scale and position to match it!


#4

Hey Thanks buddy, It worked like a charm :grinning:


#5

Thanks for posting this question, @frasmd! I ran into this myself, scratched my head, and let it go since I didn’t need to give anyone screenshots of the project. But, it was bugging me! Appreciate the answers @Steve_Mayze and @raghavendra.hassy.