Advice on using the nRF52832 inside the Raytac MDBT42V-P512KV2 package?

Hi everyone!

I’m working on building a very small device using an nRF52832 as the main computer. Since the device is so small I had to make a custom board (schematic attached) and decided to use the Raytac package in the title to give myself an antenna and some other features.

I’m using an nRF52 DK to program this board through the SWDIO and SWDCLK pins, which we’ve done before with the raw chip (nRF52832), but I cannot get it to work with this Raytac device. What we are doing is ungrounding Reset and DFU and then uploading our hex file through nRFconnect. It doesn’t work using the nRF command line tools either.

Any recommendations or thoughts on what might be going wrong? TLDR: Using the same programming procedure that worked to program a raw nRF52832, but now on the Raytac model in the title it isn’t working. The procedure in short is to program the chip through an nRF52 DK on the SWD pins.

PS: This is my first post here, so I apologize if the format isn’t quite right. Thank you!
raytac-design-files.pdf (311.3 KB)

I don’t know if this helps at all, as I didn’t do any coding on that board, so take this information with a grain of salt – but I once had a client that used a Raytac module using the nRF51822.

There was a separate “factory reset” pin that was wired to a pull-up and presumably pulled low to allow programming. Have you checked the datasheet for the module to see if a similar arrangement exists on your module?

It could be the factory reset or else I’ve worked with a nrf52840 raytac module where the flash had to be erase unlocked:


SWDWriteDP 1 0x50000000

SWDWriteDP 2 0x01000000

SWDWriteAP 1 0x00000001



It also depends on the scripts that you use to program vs using the jlink software

I’ve used this module quite a bit - fresh from the factory it advertises a BLE beacon. Is that picking up on your side?

There are no tricks to get it going and Jflash(lite) does a good job of programming it with SWD/SWC/RST connected.

Yeah so I think that is probably the equivalent of the DFU and Reset pins that we are pulling low. Thankyou for the thoughts though!

Thank you all for the feedback. It turns out one of the pins underneath the package wasn’t making sufficient contact with the PCB after soldering. The good news is it does work straight from the factory for programming through SWDIO/CLK.

1 Like